It is currently Fri Jan 18, 2019 10:10 am

All times are UTC - 5 hours [ DST ]


Forum rules


Please click here to view the forum rules



Post new topic Reply to topic  [ 10 posts ] 
Author Message
PostPosted: Sun Jan 06, 2019 12:58 pm 
356 Fan

Joined: Tue Apr 15, 2008 10:10 pm
Posts: 76
Location: Ozark Mtns
I have a relay I can't identify. It's a red "Mixo" marked Type 2GPL with 3 spade terminals. It was mounted under the dash to the left of the steering column attached to the bulkhead. 22+ years later I can't recall or figure out it's purpose or which wires connect to it. Any ideas?

Thanks!

_________________
Gordon Watkins


Top
 Profile  
Reply with quote  
PostPosted: Sun Jan 06, 2019 1:08 pm 
356 Fan

Joined: Wed Nov 23, 2011 10:52 am
Posts: 3475
Location: Cleveland, Ohio
I would imagine fog lights or air horns.

_________________


Top
 Profile  
Reply with quote  
PostPosted: Sun Jan 06, 2019 1:50 pm 
356 Fan
User avatar

Joined: Tue Apr 15, 2008 4:37 pm
Posts: 4057
Location: SW Los Angeles
Is there a turn signal flasher relay in the original location? Maybe an electronic flasher?

Mike

_________________
Mike Wilson
Lomita, CA
'63 B coupe


Top
 Profile  
Reply with quote  
PostPosted: Mon Jan 07, 2019 8:01 pm 
356 Fan

Joined: Tue Mar 25, 2008 9:28 pm
Posts: 3350
Old French brand, Mixo relay for Mixo snail horns, as in photo below.


Attachments:
Mixo horn relay.jpg
Mixo horn relay.jpg [ 8.89 KiB | Viewed 143 times ]

_________________
Top
 Profile  
Reply with quote  
PostPosted: Mon Jan 07, 2019 10:09 pm 
356 Fan
User avatar

Joined: Tue Apr 15, 2008 4:37 pm
Posts: 4057
Location: SW Los Angeles
If everything works on your car and it's not connected to anything, I'd remove it.

Mike

_________________
Mike Wilson
Lomita, CA
'63 B coupe


Top
 Profile  
Reply with quote  
PostPosted: Tue Jan 08, 2019 10:14 am 
356 Fan

Joined: Tue Apr 15, 2008 10:10 pm
Posts: 76
Location: Ozark Mtns
I have the usual turn signal flasher, no sign of air horns or fog lights. I do have an accessory socket and a funny toggle switch that I can't figure out. Just want to be sure this "Mixo" isn't anything critical. It does look the one Brad posted, only red. I'll keep an eye out for unusual circuits as I reconnect my wiring harness but it sounds like it was likely for some long-gone artifact.

Thanks for the feedback.

_________________
Gordon Watkins


Top
 Profile  
Reply with quote  
PostPosted: Tue Jan 08, 2019 10:40 am 
356 Fan
User avatar

Joined: Tue Oct 26, 2010 10:46 am
Posts: 382
Location: Calgary Alberta
Tag: 1957 356 A Coupe
picture ??

_________________
 


Top
 Profile  
Reply with quote  
PostPosted: Tue Jan 08, 2019 1:03 pm 
356 Fan
User avatar

Joined: Tue Apr 15, 2008 4:37 pm
Posts: 4057
Location: SW Los Angeles
Track the wiring...

Mike

_________________
Mike Wilson
Lomita, CA
'63 B coupe


Top
 Profile  
Reply with quote  
PostPosted: Tue Jan 08, 2019 1:49 pm 
356 Fan

Joined: Tue Apr 15, 2008 10:10 pm
Posts: 76
Location: Ozark Mtns
The relay was removed from the car 22 years ago so there's no wiring to track, except to see what's left when everything else is connected. I'll post a photo when I get a chance.

_________________
Gordon Watkins


Top
 Profile  
Reply with quote  
PostPosted: Tue Jan 08, 2019 2:31 pm 
356 Fan
User avatar

Joined: Tue Apr 15, 2008 4:37 pm
Posts: 4057
Location: SW Los Angeles
Thanks, keep us posted.

Mike

_________________
Mike Wilson
Lomita, CA
'63 B coupe


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Carl Register, Doug McDonnell, Emil Wojcik, Glenn Burgess


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group